dear community:
Is there something wrong here? Should it be changed to this?Is there a missing parenthesis in the source code?
“output[iDim] = _sDataMN.getBlock(iCloc).get(input+1,iDim)-_sDataM.getBlock(iCloc).get(input+1,iDimM) *_sDataN.getBlock(iCloc).get(input+1,iDimN)/_ensembles/_ensembles;”
output[iDim] = (_sDataMN.getBlock(iCloc).get(input+1,iDim)-_sDataM.getBlock(iCloc).get(input+1,iDimM) *_sDataN.getBlock(iCloc).get(input+1,iDimN)/_ensembles/)_ensembles
template <typename T>
bool SuperLatticeTimeAveragedCrossCorrelationF3D<T>::operator() (T output[], const int input[])
{
int iDim =0;
T iCloc = _sDataMN.getLoadBalancer().loc(input[0]);
for (int iDimM=0; iDimM<_sFunctorM.getTargetDim(); iDimM++) {
for (int iDimN=0; iDimN<_sFunctorN.getTargetDim(); iDimN++) {
output[iDim] = _sDataMN.getBlock(iCloc).get(input+1,iDim)-_sDataM.getBlock(iCloc).get(input+1,iDimM) *_sDataN.getBlock(iCloc).get(input+1,iDimN)/_ensembles/_ensembles;
iDim++;
}
}
Thanks!