Skip to content

Compiler problems on IBMs BlueGene/Q

OpenLB – Open Source Lattice Boltzmann Code Forums on OpenLB General Topics Compiler problems on IBMs BlueGene/Q

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #1744

    Dear all,rnrnI’m trying to compile the cavity3d_cuboid_mpi example on IBM’s BlueGene/Q supercomputer. As required by the BlueGene/Q system, IBM’s XL compiler was used in the compilation. The options (in are shown as follows:rnCXX := mpixlc_rrnOPTIM := -O3 -WallrnDEBUG := -g -DOLB_DEBUGrnCXXFLAGS := $(OPTIM)rnLDFLAGS :=rnPARALLEL_MODE := MPIrnMPIFLAGS :=rnOMPFLAGS := -fopenmprnBUILDTYPE := precompiledrnUnfortunately, I got error messages which I enclosed below:rn“”../../src/external/boost/boost/cstdint.hpp””, line 110.9: 1540-0130 (S) “”::int64_t”” is not declared.rn””../../src/external/cvmlcpp/base/stl_cstdint.h””, line 34.28: 1540-0040 (S) The text “”int64_t”” is unexpected. “”boost::int64_t”” may be undeclared or ambiguous.rn””../../src/external/boost/boost/integer_traits.hpp””, line 94.49: 1540-0724 (W) The non-type template argument “”2147483648″” of type “”T”” has wrapped.rn””../../src/core/units.hh””, line 158.30: 1540-0157 (S) The text “”>”” is unexpected. It may be that this token was intended as a template argument list terminator but the name is not known to be a template.rnrnIt will be appreciated if anyone who has experience of compiling OpenLB on high performance computing platforms can provide some suggestions. Thanks.rnrn


    Dear Yanhen,rnrnPlease try the flag “”-D__aligned__=ignored””. If this is not working google for the problem “”::int64_t”” is not declared””. It seems to be a problem with the included boost. If this is also not working, you can install your own boost if not done and link it. For that you need to change the line “” src/external/boost “” to your own path.rnrnMathias

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.