Skip to content

GPU Usage for Resolved Particle Dyanmics

OpenLB – Open Source Lattice Boltzmann Code Forums on OpenLB General Topics GPU Usage for Resolved Particle Dyanmics

Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #7743

    Hello OpenLB community,

    I changed the config file to gpu_only and tried to run some of the examples. While compiling, some warnings started to appear however the simulation ran. But for any of the particles example file it stated that there is an error and it can not be ran. Is the resolved particle system not adapted to the be run by a gpu?

    The error goes as:
    ../../../src/functors/lattice/latticeMomentumExchangeForce.hh(292): error: no instance of function template “olb::particles::resolved::momentumExchangeAtSurfaceLocation” matches the argument list
    argument types are: (T *, olb::Vector<T, 2U>, const int *, const olb::BlockGeometry<T, 2U>, olb::BlockLattice<T, DESCRIPTOR>, const olb::UnitConverter<T, DESCRIPTOR>, olb::particles::Particle<T, PARTICLETYPE>)
    if ( particles::resolved::momentumExchangeAtSurfaceLocation(,

    My system uses an RTX 3060 and the following config file is used:
    # Example build config for OpenLB using CUDA on single GPU systems
    # Tested using CUDA 11.4
    # Usage:
    # – Copy this file to OpenLB root as
    # – Adjust CUDA_ARCH to match your specifc GPU
    # – Run make clean; make
    # – Switch to example directory, e.g. examples/laminar/cavity3dBenchmark
    # – Run make
    # – Start the simulation using ./cavity3d

    CXX := nvcc
    CC := nvcc

    CXXFLAGS := -O3
    CXXFLAGS += -std=c++17 –forward-unknown-to-host-compiler



    # for e.g. RTX 30* (Ampere), see table in for other options
    CUDA_ARCH := 86



    I have implemented CUDA and its toolkit according to the user guide.


    The particle code currectly does not supported GPUs. Join the team and contribute to acceparate the refacturing or support us bymeans of a membership of the OpenLB consortium.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.