Skip to content

HPC: Run OpenLB in GCC-8.2.0

Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #6185
    achodankar
    Participant

    Hello Developers,
    I am trying to run OpenLB on HPC. I am running it with GCC-8.2.0 compiler. It’s giving me errors during compilation.

    Here is the link of image showing the errors: https://ibb.co/WPw08g0

    Is there any requirement for a particular version of GCC to compile OpenLB in HPC?

    Are there any recommendations while compiling openlb on HPC?

    I would really appreciate your help in this matter.

    Thank you.

    Yours sincerely,

    Abhijeet C.

    • This topic was modified 8 months, 3 weeks ago by achodankar.
    • This topic was modified 8 months, 3 weeks ago by achodankar.
    #6192
    mathias
    Keymaster

    The libary “features.h” is missing which has nothing to do with OpenLB. It seems that the compiler are not installed correctly.

    #6193
    achodankar
    Participant

    Hello Mathias,
    I will try to check if the compiler installation on the HPC is correct. Thank you for your prompt response.

    Thank you.

    Yours sincerely,

    Abhijeet C.

Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.