Skip to content

Terminal output error while compiling example files

OpenLB – Open Source Lattice Boltzmann Code Forums on OpenLB General Topics Terminal output error while compiling example files

This topic contains 4 replies, has 3 voices, and was last updated by  mathias 2 months, 2 weeks ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #2020

    rffan78
    Participant

    Hi everyone.
    I constantly get “./tmp/imageData/data/heatMapl2physVelocity.p”, line 5: unexpected or unrecognized token” this and this type of error messages(see image) while compiling the example files as indicated in the olb guide. It does not seem normal to me as I haven’t seen this output in the bstep2d terminal output depicted in the user guide. Does anyone have an idea of why I get this error?

    multicomponent2d: https://ibb.co/jGfRCXp https://ibb.co/sW628Wp
    porouspoiseuille2d: https://ibb.co/rFzmN9n https://ibb.co/3pPZYSt (I also cannot run porouspoiseuille2d since I get a lot of error messages as seen in the picture. Only 225 steps is compiled and no vtk output. https://ibb.co/4FV7Z9S)

    I also get the same error in bstep2d terminal output as in porouspoiseuille2d terminal output.

    Thanks in advance for anyone’s help.

    #3000

    Marc
    Participant

    Hey rffan78,

    i am sorry for that annoying bug. Please change in openlb/src/io/gnuplotHeatMapWriter.hh line 155:
    fout << “}”;
    to
    fout << “}” << “\n”;

    Best,
    Marc

    #3649

    rffan78
    Participant

    Hi again, I think I did what you have proposed to me but I still have exactly the same problem.
    Here are the screenshots: https://ibb.co/CsgnN6Y https://ibb.co/z2CZtrC

    I would like to remind you that these are just unmodified example files that I am just trying to run. I am just guessing; I presume these example files are being checked before releasing the official version, so I think this may happen(just maybe) because of my ubuntu version or something like that(or maybe due to C++ compiler, I am not expert at it). Since you proposed me this solution I think you had checked it by yourself and verified. If you do not take it private, which software and the version are you using? So that we can come up with something which causes this error.

    • This reply was modified 2 months, 2 weeks ago by  rffan78.
    • This reply was modified 2 months, 2 weeks ago by  rffan78.
    #3736

    rffan78
    Participant

    UPDATE:
    I cannot edit the message after some time I think ,so I am writing the update as a separate reply.
    I deleted everything and extracted the zip and did what you have proposed to me. Thank you very much. I do not have this error now. However, I still have the same error which I had in porousPoiseuille2d. Here are both screenshots. https://ibb.co/QpmwrtG https://ibb.co/Y3dR4kY

    • This reply was modified 2 months, 2 weeks ago by  rffan78.
    #3850

    mathias
    Keymaster

    That is not an error, that is an output, telling you that something about the error of the numerical results. Best Mathias

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.